Roll over sensor location?

Cruz1n

Total noob
Location
Usa
2022 Himmy, Euro 4, I was having a stalling issue, and cold start stalling constantly. Stalled on my wife while she was riding and she fell over with small injury. So I decided to look into this (the bike is only a week old.)

I adjusted the TPS to get a voltage of .70.. was trying different settings, but found .70 was working, although the idle was a little high. Parked the bike, got my 10mm wrench and unbolted the tank to lift for access to the idle screw, only lifted the rear of the tank about 3 inches, saw the adjuster screw, laid the tank back down to start the engine, and it now only runs about 3 seconds and dies.

Checked the fault codes and have a TPS sensor malfunction and a roll over sensor circuit malfunction..

These will not clear, and the bike will not run.. it still starts for approx 3 seconds and dies completely. The fuel pump primes, and the engine runs off that fuel till it dies 3 seconds later.

Anyone know where this roll over sensor is on this bike?

Thanks!
 

Cruz1n

Total noob
Location
Usa
Well, I figured out the issue, for anyone who ever finds themselves in this situation.

The roll over sensor is located under the tank near the air injection system.

The sensor has a short lead to the plug, because of its close proximity to the tank mount, it can be easily knocked loose when tilting the tank upwards to access the idle screw.

I finally removed the tank completely to find the sensor, removed the plug, and re-seated it. The bike started right up, and I was able to clear the codes. Adding a picture to show the location of the plug and sensor (my index finger is on the sensor,) and the plug is just below and next to the rubber tank mount.


6680
 

RotorWrench

Well travelled
Location
USA
Thanks for the heads up. I have the sensor on my To-Do list for checking and sealing connectors this winter but hadn't located it yet.
 
Top Bottom